Перейти к содержимому


Перед регистрацией ознакомьтесь с темой про сертификат безопасности:
Фотография
- - - - -

AE CC 2014 и Nvidia GTX 980


  • Please log in to reply
10 ответов в этой теме

#1 Barsuk

Barsuk

    Есть камера, комп, а где поля ?

  • Писатели
  • PipPipPipPip
  • 197 Сообщений:

Отправлено 11 Feb 2015 - 05:21

По осени собрал новый комп, поставил видео Nvidia GTX 980.

В итоге перестала работать поддержка  композиций Ray-Traced 3D.

 

Сообщения "Initial shader compile failed" и "Ray-traced 3D: Out of paged mapped memory for ray tracer. Your project may exceed GPU limits. Try closing other applications. Try updating the CUDA driver. ( 5070 :: 2 )"

 

Грешил на драйвер, ждал выхода новых версий, но их с тех пор штук пять если не больше вышло, а толку ноль.

Думал, что проблема связана именно с  AE CC 2014, но установка старых версий AE показала, что проблема сохраняется.

 

Редактирование текстовика со списком видях не помогает. Запуск батника от одного известного американского товарища тоже бесполезен.

 

Где собака порылась?


Сообщение отредактировано Barsuk: 11 Feb 2015 - 05:31


#2 Alf_Zetas

Alf_Zetas

    Вставляю своих 5 копеек

  • Модераторы
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 10863 Сообщений:

Отправлено 11 Feb 2015 - 12:02

в файлике raytracer_supported_cards.txt нет ни одной карточки на микроархитектуре Maxwell - очевидно, что она не поддерживается…



#3 Barsuk

Barsuk

    Есть камера, комп, а где поля ?

  • Писатели
  • PipPipPipPip
  • 197 Сообщений:

Отправлено 11 Feb 2015 - 13:07

Это типа что, до след. версии AE, можно расслабиться? :)



#4 Alf_Zetas

Alf_Zetas

    Вставляю своих 5 копеек

  • Модераторы
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 10863 Сообщений:

Отправлено 11 Feb 2015 - 13:12

ага



#5 Barsuk

Barsuk

    Есть камера, комп, а где поля ?

  • Писатели
  • PipPipPipPip
  • 197 Сообщений:

Отправлено 21 Jun 2015 - 13:59

СС 2015 так и не поддерживает карты GTX 9ххх

Обалдеть :rofl:



#6 Alf_Zetas

Alf_Zetas

    Вставляю своих 5 копеек

  • Модераторы
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 10863 Сообщений:

Отправлено 21 Jun 2015 - 16:04

это всего лишь минорный апдейт - с 13.2 до 13.5

Адоб все силы бросил на переделку движка АЕ под интерактив, но с 14.0 так и не успел вовремя :(



#7 Barsuk

Barsuk

    Есть камера, комп, а где поля ?

  • Писатели
  • PipPipPipPip
  • 197 Сообщений:

Отправлено 21 Jun 2015 - 16:56

Спасибо, сразу полегчало)

Интересно, долго ли ждать 14? К осени? Или уже в следующей версии CC.


Сообщение отредактировано Barsuk: 22 Jun 2015 - 01:52


#8 borzoff

borzoff

    А что такое камера, NLE?

  • Читатели
  • Pip
  • 2 Сообщений:

Отправлено 02 Jul 2015 - 18:54

Привет! обнаружил способ, чтобы raytrace 3d работал. оказалось что компания adobe не обновила библиотеку optix. в комплекте с after effect  идёт версия 3.0.0 это август 2013. в ней нету поддержки карт на архитектуре "maxwell" 
я скачал с сайта Nvidia optix версии 3.8 и просто заменил файл optix.1.dll. и о чудо у меня На моей карте заработал ray-trace 3d.
сегодня я проверил на работе на gtx 970 и на связке 2x gtx 980 везде нормально работало
 
мини инструкция
2. зделайте бэкап c:\Program Files\Adobe\Adobe After Effects CC 2014\Support Files\optix.1.dll я просто переименовал optix.1.dll в optix.1_bak.dll
3. скопируйте скачанный файл в c:\Program Files\Adobe\Adobe After Effects CC 2014\Support Files\ 
4. в настройках after effect включите  "Enable untested, unsupported CPU for CUDA acceleration or ray-traced 3D renderer" или можете добавить свою карту в c:\Program Files\Adobe\Adobe After Effects CC 2014\Support Files\raytracer_supported_cards.txt
5. Profit

 

скриншоты

https://www.sendspace.com/file/h41657
https://www.sendspace.com/file/q6hxeo

Работает на: gtx 750 ti, gtx 970, gtx 980, gtx 980 ti, gtx titan X. И на мобильных картах 8xxm серии



#9 Barsuk

Barsuk

    Есть камера, комп, а где поля ?

  • Писатели
  • PipPipPipPip
  • 197 Сообщений:

Отправлено 06 Jul 2015 - 04:02

 

Привет! обнаружил способ, чтобы raytrace 3d работал.

Круто)) Спасибо, все работает!

Новый optix.1.dll почти вдвое меньше старого, в связи с этим интересно, со старыми картами эта dll-ка будет работать или нет. Впрочем, это не важно.

 

Вот как после такого думать об этих ...!  :crazy:


Сообщение отредактировано Barsuk: 06 Jul 2015 - 13:54


#10 Alf_Zetas

Alf_Zetas

    Вставляю своих 5 копеек

  • Модераторы
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 10863 Сообщений:

Отправлено 06 Jul 2015 - 12:31

на оффсайте нвидии написано

but commercial applications now require a Commercial License to redistribute OptiX 3.5 and later.

 

:(



#11 borzoff

borzoff

    А что такое камера, NLE?

  • Читатели
  • Pip
  • 2 Сообщений:

Отправлено 08 Jul 2015 - 12:34

на оффсайте нвидии написано

:(

Ну может конечно adobe поэтому и не обновила библиотеку! но не думаю что это слишком дорого для такого гиганта как adobe.


Круто)) Спасибо, все работает!

Новый optix.1.dll почти вдвое меньше старого, в связи с этим интересно, со старыми картами эта dll-ка будет работать или нет. Впрочем, это не важно.

 

Вот как после такого думать об этих ...!  :crazy:

ну с gtx 770 на работе всё нормально работает! мне кажется они просто оптимизировали библиотеку. и они в версии 3,8 убрали поддержку 32bit.  и драйвера нужны R355+

 

в общем вот 

 

Limitations in OptiX 3.8

ALL 32-bit support has been removed.

 DirectX 9 Interop support has been removed in the driver. DirectX 9 Ex will continue to be supported. We recommend porting the application to DirectX 11.

 SM 1.X GPU support has been removed. This includes G80 through GT2XX-based GPUs.

 VCA on Mac does not use CUDA accelerated video stream decompression. All modes are available, but the “h264” mode is implemented on the CPU, rather than the GPU.

 Driver R355 or newer is required for optimal performance on Maxwell GPUs. OptiX 3.8 supports Maxwell GPUs on earlier drivers, but at up to 20% lower performance.  A CUDA compiler bug that causes timeouts or crashes on Maxwell cards has been worked around. Unfortunately, this bug fix causes a slowdown of up to 20% on Maxwell cards unless driver R355 or newer is used.

 OptiX supports running with NVIDIA Parallel Nsight but does not currently support kernel debugging in Nsight. In addition, it is not recommended to compile PTX code using any -G (debug) flags to nvcc.

 All GPUs used by OptiX must be of the same MAJOR compute capability, such as compute capability 3.x or 5.x, and may only differ in minor compute capability by 0.2. OptiX will automatically select the set of GPUs of the highest major compute capability and only use those. For example, in a system with a GeForce GTX 460 (compute 2.1) and a GeForce GTX 480 (compute 2.0), both will be used, but in a system with a Quadro 6000 (compute 2.0) and a Quadro M6000 (compute 5.2) only the compute 5.2 device would be selected. Applications may explicitly choose which GPUs to run, as is done in the progressive photon mapper sample, ppm.cpp, at the start of initScene(), but if the application requests a set of devices of different major compute capability an error will be returned.

 malloc() and free() do not work in device code.

 Linux only: due to a bug in GLUT on many Linux distributions, the SDK samples will not restore the original window size correctly after returning from full-screen mode. A newer version of freeglut may avoid this limitation.

 Several OptiX SDK samples are intended to run on a single GPU and will perform more slowly when run on multiple GPUs. The samples: Cook, Hybrid Shadows, isgReflections, isgShadows, and SimpleAnimation will only run at full speed on a single GPU. The compiled versions of these samples can be constrained to a single GPU by setting the environment variable CUDA_VISIBLE_DEVICES = N, where "N" is the number of the GPU you wish to utilize. The OptiX sample3 is a convenient means to quickly identify your device IDs.


Сообщение отредактировано borzoff: 08 Jul 2015 - 12:41



0 человек читают эту тему

0 пользователей, 0 гостей, 0 скрытых пользователей



Рейтинг@Mail.ru